Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 12 of 12
  1. #1

    Unhappy TL-R470T+ VPN (PPTP & GRE) not working

    Model :

    Hardware Version : Not Clear

    Firmware Version :

    ISP : [/COLOR]

    TL-470T+ V4

    I have tried to setup a VPN using a Windows 8.1 incoming connection on our LAN using PPTP, I have opened the port 1723 to the LAN-IP and setup a virtual server pointing to the LAN-IP, I can connect using the VPN pointing directly to the LAN-IP but using the EXTERNAL-IP on WAN2 I get the following error, I have added the protocol GRE-47 to the protocol list but there is not an option to forward the protocol to a LAN-IP.

    “The VPN connection between your computer and the VPN server could not be completed, The most common cause for this failure is that at least one internet device (for example, a firewall or a router) between your computer and the VPN server is not configured to allow Generic Routing Encapsulation (GRE) protocol packets. If the problem persists, contact your network administrator or Internet Service Provider.”

    Has anybody had experience of this problem? And if so any suggestions how to but it right?

    Thanks in advance.


  2. #2
    To me, it seems that the TL-R470T+ supports only UDP and TCP forwarding. I'm not sure but maybe you'd need GRE (which is an entirely different protocol) being routed.. please ask the support in your country..

    TP-Link has not even IPv6 support now but it is said they will catch up but they don't say when. Red flag..?

  3. #3
    I think the R470T+ does not support GRE.

  4. #4
    I've recently installed a TL-R470T+ and I opened 1723 TCP/UDP pointing to the internal server IP (and 443 for other reasons) and my PPTP VPN works normally

  5. #5

    Red face

    Name:  client setting.png
Views: 0
Size:  33.5 KBHi Guys, managed to sort out the problem I asked support to look into it and they suggested altering a few settings on the client side, namely adding CHAP & MS-CHAP v2, worked ok after that.

  6. #6
    I had this issue. Make sure PPTP is enabled in ALG.

    Then test the connection from an external source and IP. Not whilst on the same network, even attempting to connect using external IP. This is blocked and GRE does not pass through or loop back correctly.

  7. #7

    GRE on TL-R470T+

    The TL-R470T+ will pass GRE just fine, but I found the one of my ISPs DSL modem/router world not. So I had to route all GRE and port 1723 to the ISP that would pass GRE! All good!Name:  Screenshot 2015-12-01 14-50-00.jpg
Views: 0
Size:  91.5 KB

  8. #8
    You have to go in and create the GRE choice for protocol. I think at was #47??

  9. #9
    I know it's an old topic, but I had success using PPTP with this router... but, PPTP is old and insecure,
    I'm trying to use ipsec/l2tp/ikev2, and it's not working. IPSEC is enabled on ALG tab, ports are forwarded and RRAS is configured on the server, but it's not working...
    Any ideas?

  10. #10
    Please enable the IPSec ALG and open port UDP500 and UDP 4500 for your VPN Router.

  11. #11
    Hola Daniel ! Como solucionaste el tema de IPSEC en TL-R470T+ ???

  12. #12
    Hi Daniel. How did you finally resolve this issue ?


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.