Hello!
I also had this problem and after trying several solutions I found the only one that solved me definitely the problem was to disable the WPS.
Greetings from Portugal!