Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 9 of 9
  1. #1

    tp-link m7350 doesn't start - tp-link logo flashes on and off

    Model : M7350

    Hardware Version : V2

    Firmware Version :

    ISP : Proximus (Belgium)[/COLOR]

    I have four M7350 hotspots.
    2 of them boot up fine, and 2 are constantly flashing the TP-Link logo on and off.
    It can't be the battery because they're plugged in, and I'm guessing is the battery is dead I wouldn't even see the logo.

    The logo comes up for 10 seconds and then goes away again.
    I tried resetting both devices by pressing the reset button in the back but that doesn't do anything.
    It keeps flashing on and off without even registering my actions.

    Has anyone encountered this before?

  2. #2
    Members Mavis is on a distinguished road
    Join Date
    Nov 2012
    Did you try the battery of working M7350 on those don't start?
    Are they all new or they worked before?

  3. #3
    Quote Originally Posted by Mavis View Post
    Did you try the battery of working M7350 on those don't start?
    Are they all new or they worked before?
    Hey Mavis, sorry for the delay.
    Yes, I already tried exactly that.
    All 4 worked before. We gave them to employees to use abroad.
    When they came back, only 2 were in working order.

  4. #4
    Members Mavis is on a distinguished road
    Join Date
    Nov 2012
    Are they still under warranty?

  5. #5
    Quote Originally Posted by Mavis View Post
    Are they still under warranty?
    I'll have to check, but they're less than a year old, so they should be.
    I was actually hoping it'd be a known issue so I could avoid sending them back to TP?
    We have others, so it's not that we'd be without, but still

  6. #6
    Junior Member colinBroderick is on a distinguished road
    Join Date
    Jan 2017
    I realize this is a very old thread but I have exactly the same problem. My unit is about six months old but unfortunately no receipt is to be found so I doubt the manufacturer will honour the warranty. Anybody heard of a solution to this issue?


  7. #7

    Cool The first step to make it work.

    >> The first thing you all folks should know, that the modem TP-Link M7350 V 1.0 is an Android Device <<

    All flies that I post here are to download from my personal account:
    Download link: https://mega.nz/#F!N5piWRKY!JMhOgpd0I1y-eGJApsJ53w

    1. Alcatel_windows_10_x64_driver_M7350_TP_Link.zip
    2. Android_AIO_Flasher.rar
    3. M7350(UN) 1.0_1.1.1 Build 150204 Rel.1023n_User.zip (copy from http://static.tp-link.com/resources/..._V1_150204.zip)
    4. CKT Qwrite_Writer.rar
    5. M7350(UN) 1.0_1.0.11 build 141126 Rel.1014n_User.zip
    6. qualcomm_drivers.rar and QDLoader HS-USB Driver.7z
    7. QFile.rar
    8. ADB.rar

    1. This file is a driver that connect this Android Device to Windows 10 x64 peer USB 2.0 cable. (If this driver does not work by you, write to me)
    2. Universal Android Flash program, I downloaded from google.
    3. Firmware in ZIP file format for M7350 downloaded from official TP-Link web page.
    4. After installing drivers you can view your Imei and WiFi numbers.
    5. Older firmware downloaded from a Spanish web site.
    6. Qualcomm drivers working after PC restart
    7. QFIL and QPST to flash this device - but how when there is no XML in this firmware ?
    8. Original ADB working from CMD.exe in Windows 10 x64

    What I have try do make:

    I have try to upload to device the boot.img file that's in M7350(UN) 1.0_1.1.1 Build 150204 Rel.1023n_User.zip with success, but my device is still locked on TP-Link logo.
    Next step was to reboot the device from Universal Android Flash program, and it rebooted (means connection is ok). ADB Shell is working in Universal Android Flash, and normally also. I have try peer normal adb program to command:" adb reboot recovery" and then adb sideload firmware.zip but I get error "closed". I see all files on the device but I can not connect it from command line to WLAN, or update firmware.

    What is the problem ?

    Device use Qualcomm MDM9225 chip, files inside firmware:
    appsboot.mbn ; qdsp6sw.mbn ; sbl1.mbn ; boot.img

    I have seen that the same files are by flashing Qualcomm Phones by using QFIL.
    QFIL is seeing this modem as ALCATEL HS-USB Diagnostics 9025 (COM7), I can also make an QCN Backup.
    But not upload this firmware, because there is no XML data for this firmware.

    Hours searching on google I have found some application there I could chose which files to flash.

    Maybe someone has solved this problem, the driver from ALCATEL is ok, they use the same chip.

    Name:  1.png
Views: 0
Size:  14.4 KB

    Qualcomm HS-USB Diagnostics 9025 (COM9) driver is also working, but I had some problems maybe, because there were installed first Alcatel drivers.

    Maybe there is an option to make .qcn backup from working device, and upload it back to this not working. But I don't know whats inside this .qcn backup.

    It seems to me that it might help, just let someone do a backup (write the version of modem) from working device in QFIL. People make the same in mobile phones: http://forum.gsmhosting.com/vbb/f958...lcomm-2023268/

    Thx 4 Help
    Last edited by yakuzja; 01-30-2017 at 17:51.

  8. #8

    CavIT make a backup copy using QFIL from them that boot up fine, a then restore it to 2 that are constantly flashing the TP-Link logo on and off. Upload the backup here

    1. Fastboot.zip (adb + fastboot)
    2. adb-setup-1.4.3.exe (adb + fastboot)

    Maybe this could be an option also:


    1. Download the images:
    https://cyngn.com/products/oneplusone (here just our image)
    And then scroll down and download the fast boot.zip
    2. Download fast boot:
    3. un-extract the zip to C:\mango\
    4. Open cmd as admin.
    5. "cd C:\mango"
    6. Power + volume up (don't know how boot this modem into flashing mode, maybe peer Android AIO Flasher.exe if recovery mode=flash mode)
    7. Copy one and run it, then move on
    fastboot oem unlock
    fastboot flash boot boot.img
    fastboot flash system system.img
    fastboot flash recovery recovery.img
    fastboot flash cache cache.img
    fastboot flash modem NON-HLOS.bin
    fastboot flash sbl1 sbl1.mbn
    fastboot flash dbi sdi.mbn
    fastboot flash aboot emmc_appsboot.mbn
    fastboot flash rpm rpm.mbn
    fastboot flash tz tz.mbn
    fastboot flash LOGO logo.bin
    fastboot reboot
    7. Finished.

    Just I don't know how put this modem into flashing mode "Power + volume up"
    Maybe a combination of buttons, just on the damaged device, I can not check it.

    I do not have the device now, made repair for some friend, he wanted this modem back.
    Last edited by yakuzja; 02-01-2017 at 10:57.

  9. #9
    Junior Member Jan Turoň is on a distinguished road
    Join Date
    Dec 2017

    Lightbulb TP Link settings changed in low-battery state

    Just stumbled upon this thread: I have V3 and the battery was very low when I turned it on. The logo went on and off erratically and then I was out of Internet. For some reason, DHCP server went out, so I had to set the IP/mask/gateway manually to get into the admin interface and turn the DHCP back on. Since then, it works again.
    So I'd advise to double check every setting if something is not changed.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.