Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 11 of 11
  1. #1

    Question Network link between 2 sites - Good ping, terrible speed on download

    Region : UnitedKingdom

    Model : CPE510

    Hardware Version : V1

    Firmware Version : 1.1.0 Build 20150401 Rel. 55883

    ISP : 70/20MB

    Configured AP1 in Access Point mode connected to Gb network port on router
    Configured AP2 in Client mode at remote site

    Distance is only around 400 Metres
    Pings between networks <2ms

    Ping from remote site to internet are very good
    Download speed from remote site to internet are only ~250K

    Download speed from AP1 *local* network to AP2 network are around 11MB but stall periodically, dropping down to 3MB as if was some buffering issue.

    Main problem is the download speed, am I doing something wrong here?

    Is there a decent video/tutorial on setting this up? I had a similar issue with WA7210's and in the end used a cheap standard AP at the remote pointing at the WA7210

    Anyone got some screenshots of the wifi and the network tabs on a CPE510 so I can confirm I've got those both right?


  2. #2
    -Set region to test mode and set power to max (27dbm)
    -Change channel, maybe you could try using unallowed channels (5320-5500, 5835-6100)

  3. #3
    Thanks thaischumi tried already, had direct LOS and really had it down to some network or loopback issue...

    BUT... I fixed it.. I already had QOS running on the main router - and I missed that... Sorted the QOS and all seems good.

    Getting great speeds now. Just shows how easy it is to miss the obvious!

    Excellent piece of kit, and at least one big UK distributor (after seeing a demo here) is getting in touch with tp-link today to bulk order

  4. #4
    Members radvd is on a distinguished road
    Join Date
    Oct 2013
    The experience of QoS will be a good reference for other users here.

    @NIT Can you also share more details about what QoS settings you have set on the main router? I am not quite familiar with QoS settings but it interests me.

  5. #5
    You set QOS to 95% of your actual bandwidth, he must had something lower that didn't let the speed to pass
    QOS is complex, every company says a different thing about it
    This is a good read on QOS
    Last edited by danymarc; 06-24-2015 at 16:03.

  6. #6
    Members radvd is on a distinguished road
    Join Date
    Oct 2013
    Thank you @danymarc

  7. #7
    @danymarc & @radvd

    My setup uses some bandwidth/latency critical applications and devices, thus I implemented QOS. The network also daily has many temporary devices connected. Unknown devices are allocated a small slot of bandwidth for network safety/security and to ensure our critical equipment a high slot (hope that makes sense). In my case the CPE510's were 'unknown' at that point.

    After more testing of these CPE510's I have to say I am even more pleased with how they are working. My only worry is how weatherproof these boxes are as the older WA7210 seemed better build?

    I'd recommend CPE510 though, big time.

  8. #8
    Quote Originally Posted by NIT View Post
    My only worry is how weatherproof these boxes are as the older WA7210 seemed better build?
    Not to worry, works perfect in rain, I'm on rainy season no problems.

  9. #9
    Thought I'd add a little to my very old thread in case anyone else had similar issues.

    I'd assumed the QoS was making a difference, after I had everything disconnected/reconnected and QoS played with the problem disappeared.. but it did show it's head again. Turned out the real reason was a dodgy patch cable plugged into something completely different, obviously in my troubleshooting I'd disturbed the cable enough to have it working (until it was disturbed again!). Once I replaced the cable I've had even better results. Very happy to recommend this kit. TP-Link have come a long way.

  10. #10

  11. #11
    Quote Originally Posted by halinh95 View Post
    You try to optimize the QOS configuration
    Yeah, QoS was fully optimised and fine, as mentioned above the problem was actually flaky patch lead.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.