Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Failed to upgrade! solved

    Region : Argentina

    Model : TL-MR3220

    Hardware Version : V2

    Firmware Version : 1.1.3 Build 131112 Rel.31300n

    ISP :

    i start Update with Firmware M5350_V1_140311 and get this Error:
    07:37:16: M: 6(invalidE)
    07:37:17: M: 2(normal)
    07:37:17: Device CONNECTED! Port CONNECTED: 15
    07:37:24: Device SYNCHRONIZED!
    07:37:24: Compiled the current firmware: Apr 02 2010 14:42:40
    07:37:24: Failed to get device hardware version. (ERROR NO. 110.)

    Model: M5350
    Firmware Version: 1.1.3 Build 131112 Rel.31300n
    Hardware Version: M5350 v1 00000000

    what can i do to install the new Firmware?
    Last edited by jressel01; 09-18-2014 at 08:29.

  2. #2

  3. #3
    i solved the Problem.
    I get a Beta Update Tool vom TP-Link and this work.

  4. #4
    Junior Member
    Join Date
    Jan 2017
    Hi Guys,

    I'm having the same issue. Where can I find this beta update tool?


  5. #5
    Update the firmware to version 140929 http://www.tp-link.com/pe/download/T....html#Firmware

  6. #6
    Junior Member
    Join Date
    May 2017
    Quote Originally Posted by Treblklef View Post
    Hi Guys,

    I'm having the same issue. Where can I find this beta update tool?


    I'm having the same issue, where can I find the beta update tool please?
    When I try to upgrade, the display of the M5350 goes blank, and connection is lost...

    Or is there another way to upgrade (via browser?)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.