Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Page 6 of 6 FirstFirst ... 4 5 6
Results 76 to 82 of 82
  1. #76
    Hi All!

    Wow Deployed a good number of the WPA4220 model and earlier models and never encountered this problem! EvanA's solution resolved for me. Just in case anyone has my scenario here's what I encountered...........

    Ok so client wants to expand Wi-Fi around public building for staff and maybe public access. Keen to use PowerLine kit.

    In my office testing I have existing TL-PA411 & TL-WPA4220 V1.0 set up with a TP-Link router model TD-W8980
    I had to hand a TL-WPA281KIT V3 comprising of TL-PA211 & TL-WPA281 V3.0 units

    My idea is to enable port grouping on the router (IE port based VLAN)

    Ports 1-3 default IP Pool 192.168.1.x Default DHCP start at .100
    Port 4 new public group IP Pool 10.44.0.x Default DHCP start at .100

    Configure existing TL-PA411 & TL-WPA4220 with a power-line network name EG Staff
    Configure spare TL-PA211 & TL-WPA281 with power-line network name EG Public

    Then the TL-PA411 would be in say port 2 of the router and be part of the 192.168.1.x subnet
    and the TL-PA211 would be in port 4 of the router and be part of the 10.44.0.x subnet

    Set port group on the router up ok.

    The TL-PA411 & TL-WPA4220 kit is up and running and has been for months the TL-WPA4220 had an IP set of 192.168.1.3 all good!

    Here's where my day goes downhill........
    Got the TL-WPA281 out and grabbed the 1st powerline utility disk I had to hand (not necessarily the one that came with the TL-WPA281 unit!)

    As soon as I ran the Powerline scan utility I found I could NOT set the IP address of the TL-WPA281 unit and make it stick!
    Ok so lets check out the existing, working TL-WPA4220 unit I think. Low and behold this has reverted to some random IP address out of the 193.168.1.x DHCP pool!

    Today Following EvanA's solution seems to have resolved it.
    I turned all PowerLine units off and apart from setting the Powerline Network name EG STAFF or PUBLIC I set the IP address of the TL-WPA4220 to 192.168.1.3 and the TL-WPA281 to 10.44.0.3. with the Wi-Fi of the powerline adaptors OFF!
    With all plugged in and re-booted I new have two separate networks via the PowerLine and two separate subnets. Hurrah!
    Access the PowerLine Wi-Fi Adaptors via there IP address above with Browser, NOT the PowerLine Scan utility, and turn on their respective WiFi All good! Big Hurrah!

    I will test for a few days to see if these settings all 'stick' as I intend!

    I conclude that with Wi-Fi on, the version of the PowerLine Scan utility I used was hunting the attached Wi-Fi subnet I'd initially started with or causing the Wi-Fi Powerline adaptors to do so (Smart Scan) IE 192.168.1.x (which will typically be the norm for most people or 192.168.0.x)
    It's just trying to be too clever! the old acronym KISS comes to mind!

    Another way to cope with this might be to assign some IP/MAC address assignments in the Router DHCP allocation pool. But that's boring! and in a large setup a pain!

    I'm did not have any to hand but I thought some of the very early versions of the TP-Link Wi-Fi and an option for Static IP. (Might be wrong!) but it's definitely something that would be very desirable in any future firmware updates please!
    Last edited by sjgnet; 11-29-2016 at 15:51.

  2. #77

    Cool wifi problem/dhcp/ios

    I bought TL-WPA4220 Powerline Extender connected to a TL-WPA2220Kit.
    I used to have wifi problems with WPA4220: connection dropping twice a day, broadcast/DCHP not assigning ip address, specially with IPhone and IMac (PCs and Androids less problems). Sometimes assigning static IP address would work (but not for more than 1 or 2 days) so I plugged another wifi router to the WPA4220 as a workaround.
    A few days ago, I realized that my firmware (v1-EU) was not updated as I had thought. TPLink download page in Brazil didnt have the latest firmware version, it shows April,2014. Visiting TPLink page in Portugal I found a new firmware dated May,2016.
    Both are same region v1(EU) and it worked for me. My problem is apparently solved.
    http://www.tp-link.pt/download/TL-WPA4220.html#Firmware

  3. #78

  4. #79

  5. #80
    Setting up a static IP was the solution and it allowed me to force an address outside the wifi/24. All clients were talking to DHCP just fine but the AP was invisible to scan probes! Whatever they have fixed it now refuse to accept my out-of-range ip and it now choose a random IP inside the wifi/24 instead. This bug was a exceptional feature, I was able to hide them all and I bought many because of it.It had a management interface, kind of, and now no more.

  6. #81
    The powerline extenders can't accept the static IP address assigned by the router.
    It only has a default IP 192.168.0.1 to manage it, if you are able to login to the management page, you can change it into the DHCP range of your router.

  7. #82
    Quote Originally Posted by uutommi View Post
    The powerline extenders can't accept the static IP address assigned by the router.It only has a default IP 192.168.0.1 to manage it, if you are able to login to the management page, you can change it into the DHCP range of your router.
    I probably wasn't clear enough. Before: I setup a 1.245/24 IP in the AP inside a VLAN where DHPC leases out 20.0/24. All great, AP was invisibile to discovery scans. Now: I do the same but the AP refuses to use an IP outside the 20.0/24. It works as it should but the AP is now, obviously, visible. I do not have problems, I'm just pointing out that after understanding the bug I was able to use it to add a tiny layer of security in my 802.1x WIFI. I would also need to add that using an IP inside the DHCP range is wrong as this may cause duplicate IPs. Instead you all should use an IP outside the DHCP range but still inside the subnet. Cheers.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.