Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 11 of 11
  1. #1

    TP-LINK Powerline Problems

    Region : UnitedKingdom

    Model : TL-PA210

    Hardware Version : V2

    Firmware Version :

    ISP : Talk Talk

    Basicly, lately i have been either getting DDoSed or network problems, im guessing DDoS because it happens every now and then, and i rarely every used to disconnect, maybe i am wrong, anyway, when i get disconnected, internet comes back up, wireless works on ipad, phone and laptop. my pc which is connected via TP-Link Powerline does not, it doesn't even recognize my network, it says 'Unidentified Network' or just says my provider but says it isn't connected, mainly 'Unidentified Network' I am really annoyed about this, the only way i can fix this is resetting my router like 3 times each time, it's a waste of my time, and i am thinking of going on to just use wireless (bad for me, far from router)

    Anybody else having this problem? or anybody know how to fix it?

  2. #2
    It seems that the connections between two Powerline adapters are not stable. Check the lights on the powerline adapter and make sure all three lights are green on,especially the second light. If they are not, you can try to reset them by the TP-LINK Utility by the CD or go to the TP-LINK website to download one. Second, Check the cables connected to the router and the LAN ports on the router are working properly.

  3. #3
    This is just stupid now, i have reset them and now it doesn't even say that they are connected to my pc, let alone my internet, these TP-Link powerline adapters have been one big mistake for me so far, but i am willing to try and get them fixed.

  4. #4
    Maybe you can try to pair them in this way:
    1. plug the adapters into the same extension socket or in the same room.
    2. press the pair button on adapter A for 5 seconds (Note that it’s not press the pair button until the lights flash).
    3. press the pair button the adapter B for 5 seconds within 2 mins. Wait for about 1min and then check whether the middle light will light up or not.
    You may repeat the steps for 2 or 3 times.

  5. #5
    This worked for me. Got the connection but not very fast 91mbps. I put the 2 powerline devices on the same power outlet and got 194mbps but when I went back to separated rooms then it lowered to 70-91mbps.

  6. #6

    tplink power lan suddenly stopped working

    Hi, same problem as someone else, my network was working alright til suddenly, yesterday it stopped working, it's just the addapters I know, 'cause I have internet and lan in the rest of the computers, just the one connected through tplink is not accesing net, upper and lower lights on and stable, middle one off; same result after trying procedure many times. Any suggestions? thanks in advance

  7. #7
    Members Ada is on a distinguished road
    Join Date
    Oct 2012
    Did you try to pair them again or reset both? Since middle light goes off, it seems that they are not commumicating with each other.

  8. #8
    Hi Guys

    Just wanted to share my experience with TP-Link powerlines.
    If you can't get a good connection, try these
    1, reset the Powerlines to clear the pairing
    2, use a power strip or surge strip to test the powerlines
    3, if confirmed they are working, try installing them on your target areas

    Normally of both wall outlets belong to the same circuit box, they should work properly.

    Hope these helps.

  9. #9
    I thought I would share my experience today as it might save some people some time and anxiety.

    I have been using a TP-Link adapter and wireless extender for a couple of months and, until today, never had a significant problem. The adapter is plugged into a socket in an upstairs bedroom; the extender is plugged in downstairs, with an ethernet cable into a smart TV; we also use the WI-FI downstairs for Ipad, etc. As I've said, until today, no significant problems.

    Then today I got exactly the problem described above: powerline LED out on the adapter, powerline LED on the extender flashing intermittently: most important, nothing coming through to smart TV or anything else.

    Having searched the internet for suggestions, I re-paired the adapter and extender; it didn't make the slightest difference. So then I experimented a bit. I tried the extender (not connected to anything) in upstairs sockets, instead of its usual downstairs socket. It worked fine, but it's no use to me up there. It then occurred to me that, since I hadn't had the house re-wired overnight, there was no obvious reason for it not to work downstairs, so I tried to think what else might be the cause. It then occurred to me that the tumble-drier was on, plugged in downstairs. So I waited until the tumble-drier was finished, then restarted my router and the home plugs and, hey-presto, right as rain!

    So, I would suggest that before you go through the bother of re-setting/re-pairing adapter and extender, check what electrical appliances you have running at the time and see whether turning them off fixes the apparent homeplug problem.

  10. #10
    Junior Member macnik is on a distinguished road
    Join Date
    Nov 2017
    Hi, same problem here, but im my case when i try to re-pair them the emisor adaptar keep blinking for 2 minutes but the receptor blink just 3 times and then stop :| ... any one has the same problem !?!?!?

  11. #11
    Unplug the receiver and replug it. Try one more time.
    Using the way below to add a device or change the network name of the two devices.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.