Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 13 of 13
  1. #1

    TL-ER5120 Not Detecting WAN Down

    Region : UnitedStates

    Model : TL-ER5120

    Hardware Version : V1

    Firmware Version : 1.0.2 Build 20120719 Rel.43150

    ISP : Multiple


    The router is set up to use 3 WAN connections, with each going through a switch or router prior to reaching the TL-ER5120. Since the switch or router may remain online when the connection to the ISP has been lost, we have the WAN ports set Active in "Online Detection" to detect (Ping & DNS Lookup) manually-specified IP addresses on the Internet. However, when the ISP connection is lost, the TL-ER5120 does not detect the loss of connectivity and continues trying to route traffic through the failed WAN because it sees the local switch. Assuming we have this set up correctly, this is a significant defect.

    There needs to be a way to set how often the Ping & DNS Lookup are attempted, and after how many errors it disables the WAN.

    There also needs to be a way for the router to send an email to an admin to alert them of alarms.

  2. #2
    I have been using the TL-ER5120 for a while now with 4x WAN setup and have to manually unplug the failed WAN connections.

  3. #3

    same issue with TL-R470T+ v2.1

    Has anyone got a solution for this? We have the same problem with our TL-R470T+ v2.1. Only if the network cable is physically unplugged does the router recognise the link as down. Thus requests continue to be routed to the down link and users get no Internet.

  4. #4
    Hi guys!

    I think I get a solution.
    I find that online detection works in Auto mode by default.
    In this mode, the router determines the status of the line by PINGing the gateway of its WAN interface and sending DNS requests to its WAN.
    As long as one of the two operation get a response, the router thinks the WAN is active.

    If there's another router in front, and the line disconnected on WAN of the front router.
    TP-LINK router can still get a response while PINGing its gateway, so it thinks itself online even if the line is running an error.

    However, TP-LINK still offers a manual mode as well as auto mode for online detection.
    We can change the mode to manual and fill the IP address of Google DNS(8.8.8.8 or 8.8.4.4) or OpenDNS (208.67.222.222) in the blanks after ping and DNS lookup.

    I have tried this with my TL-ER6120 and it works perfectly.

  5. #5
    Hello,

    Can you tell me in wich menu I can turn Auto detection to Manual detection.

    I can not find it.

    Thanks

    Quote Originally Posted by sylvanas View Post
    Hi guys!

    I think I get a solution.
    I find that online detection works in Auto mode by default.
    In this mode, the router determines the status of the line by PINGing the gateway of its WAN interface and sending DNS requests to its WAN.
    As long as one of the two operation get a response, the router thinks the WAN is active.

    If there's another router in front, and the line disconnected on WAN of the front router.
    TP-LINK router can still get a response while PINGing its gateway, so it thinks itself online even if the line is running an error.

    However, TP-LINK still offers a manual mode as well as auto mode for online detection.
    We can change the mode to manual and fill the IP address of Google DNS(8.8.8.8 or 8.8.4.4) or OpenDNS (208.67.222.222) in the blanks after ping and DNS lookup.

    I have tried this with my TL-ER6120 and it works perfectly.

  6. #6
    Hello,

    Can you tell me in wich menu I can find this option to turn auto online detection to manual

    i can not find it

    Thanks

  7. #7
    Members Ada is on a distinguished road
    Join Date
    Oct 2012
    Posts
    1,143
    Maintenance---Diagnostics---Online Detection
    Give a try there.

  8. #8

    Talking Thank you Sylvanas!

    I found the option in the TL-R470T+ v4 settings and I'll try link backup feature soon.
    Only knowing this way to solve the problem is great! I think that the others solved it too because they did not replied your post.
    It's strange TP-Link set this option on Maintenance page, it could be set on Load Balance policies page instead.

    Thank you very much for the tip and the explanation. I thought that it was a kind of a bug in the router!

    Best regards.

  9. #9

    I have the same issue on my TL-R480T+ Ver 5.1 but on the Wan 2 after 10 minutes.

    I Have a the same issue on my TL-R480T+

    Thank you in advance before I fix it in my office so I will give U a feed back as soon as I see it working.

    See you soon..


    Franklin

  10. #10

    Red face It worked thank you

    Hi sylvanas,

    Thank you for the solution, it seems to be finally working for my TL-R470T+ load balancer. I have added the DNS lookup as 8.8.8.8 for my Wan1 keeping the ping as 0.0.0.0 and similarly for the other WAN ports. I hope this is correct and keeping ping as 0.0.0.0 will not have any issues. If it should be something else, do let me know.

    Regards
    Aditya

    Quote Originally Posted by sylvanas View Post
    Hi guys!

    I think I get a solution.
    I find that online detection works in Auto mode by default.
    In this mode, the router determines the status of the line by PINGing the gateway of its WAN interface and sending DNS requests to its WAN.
    As long as one of the two operation get a response, the router thinks the WAN is active.

    If there's another router in front, and the line disconnected on WAN of the front router.
    TP-LINK router can still get a response while PINGing its gateway, so it thinks itself online even if the line is running an error.

    However, TP-LINK still offers a manual mode as well as auto mode for online detection.
    We can change the mode to manual and fill the IP address of Google DNS(8.8.8.8 or 8.8.4.4) or OpenDNS (208.67.222.222) in the blanks after ping and DNS lookup.

    I have tried this with my TL-ER6120 and it works perfectly.

  11. #11

    No Ping in TL-R470T+

    There is no Ping in the menu of TL-R470T+. Where can I add an IP Adress then?
    Quote Originally Posted by aditya_a_a View Post
    Hi sylvanas,

    Thank you for the solution, it seems to be finally working for my TL-R470T+ load balancer. I have added the DNS lookup as 8.8.8.8 for my Wan1 keeping the ping as 0.0.0.0 and similarly for the other WAN ports. I hope this is correct and keeping ping as 0.0.0.0 will not have any issues. If it should be something else, do let me know.

    Regards
    Aditya

  12. #12
    Found it. See Maintenance Diagnostics Online Detection

  13. #13
    Yes that is right, it is little difficult to find out. I have added 8.8.8.8 as DNS and google's ip address to decide whether the ISP is online or not and it is working really well.

    Quote Originally Posted by MichaelSch View Post
    Found it. See Maintenance Diagnostics Online Detection


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.