Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    How to recover a bricked Archer d7?

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Model Archer D7

    Hardware Version : 1.1 (EU)

    Firmware Version : was 170303

    Something got wrong during a firmware update and now my D7 is totally unresponsive. Only the power light is on. I can no longer see the wifi name of the router, wired connection doesn't work anymore and I can't log in the web interface. I have already tried to follow the procedures in this link (https://www.tp-link.com/uk/faq-1482.html), but whitout success. I have also been trying to follow these instructions here (http://forum.tp-link.com/showthread....you-bricked-it) to recover using TFTP, but nothing happens. Does archer d7 can't be recovered using TFTP or the instructions doesn't apply to this model?

  2. #2
    it looks like D7 doesn't support firmware recovery. you need to contact tp-link support and check the warranty

  3. #3
    What about that serial thing? Do you think it supports?

  4. #4
    Have you tried the factory reset option with the reset button in the side of the router?

    If that doesn't work it looks like a paperweight I'm afraid unless there is a shop you can take it to who can do FW level reprogramming, you'll need to compare the cost of a new router to what they will charge you first though, never send good money after bad.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.