Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 5 of 5
  1. #1

    Help needed with TP Link Utility program

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I have a TL-PA7020P powerline adaptor set. The utility program does not recognise the adaptor when I plug my computer into it.I do not have a copy of the older version of the utility program. I am running windows 10. Can anyone help me please?

  2. #2
    You are using the tpPLC utility? Make sure the Ethernet led is lit when the adaptor connects to your computer. And see if you can disable firewall and antivirus on the computer, run the utility program again. Or reinstall the utility.

  3. #3
    Thanks for the reply. I tried your suggestion. It didn't work. My adaptors are V1.

  4. #4
    Members Ada is on a distinguished road
    Join Date
    Oct 2012
    is the ethernet light on? can you try another computer? maybe the port is faulty.

  5. #5
    The ethernet light is on. I tried both ports. I used a different laptop. I changed the Ethernet cable . I tried resetting the power line, the utility program still does not register the adaptor. I am at a complete loss.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.