Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 2 of 2

Thread: Tl-pa7010p kit

  1. #1

    Tl-pa7010p kit

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]


    First post here. Tried to research if someone is having the same problem but could not.
    So I own 2 pairs (4 in total) of TL-PA7010P KIT. My internet modem (that also acts as a gigabit switch) is Hiltron CODA 4582. It has 4 gigabit ethernet ports at the back.
    I have connected one of these TP Links directly to the wall socket and, and the Ethernet cable to my modem's Ethernet port. My modem is able to negotiate only 100 MBPS speed even though TPLINK says it is a gigabit powerline adapter. The other TPLink endpoint is in the same circuit again plugged directly to the wall. Even if I disconnect all 3 TPLINKs from wall socket and leave only the single one attached to modem. Modem logs are showing that it can only negotiate 100 MBPS full duplex with TPLINK.
    I connect my laptop to another port of the same modem and it is negotiating gigabit connection. I switch cables thinking cable is the problem, same thing, TPLINK stays at 100 MBPS. I used CAT5E, CAT6, CAT7 cables, all same thing.
    I took modem to the ISP, they could not find anything, even swapped with brand new one. Still same problem.
    I tried using any of the available 4 TPLINK adatpers, all negotiate at 100 MBPS full duplex, none can negotiate at a gigabit.
    What is this? Is it a wrong advertisement from TPLINK? Advertising 100 MBPS device as a gigabit device? Please note that I am not looking to get gigabit speeds out of TPLINK. Even if I get 200 MBPS I would be happy, but being locked at 100 MBPS is very restrictive. I have professional videos shot by HERO6 that are like 120 MBPS, streaming these videos from home nas to my laptop simply causes stuttering video performance.
    Is there a way to solve this?
    I contacted TPLINK support they seem to be clueless.

  2. #2
    Connect your laptop to the tplink via Ethernet cable and check the link speed on your laptop. Like the first pictures show here.

    If it does show 100mps, then you need to contact tplink support, email them


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.