Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 9 of 9
  1. #1

    TL-WA855RE - MacBook

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]


    I have a problem with TL-WA855RE V2.0 to connect a MacBook Pro.
    The Wi-Fi is visible, but don't accept the Wi-Fi password.

    With Windows and Iphone is work.

    The Firmware is updated to latest version - TL-WA855RE(BR)_V2_171116

  2. #2

    I am using a Macbook Pro 15" with the latest updates for macOS High Sierra. I am getting the same issue when trying to log into a brand new RE305. When connecting to the Extender, I am prompted with a request for password. The connection is attempted and fails, with an error of invalid password and prompts for it again. My Windows 10 laptop and my iPhone 6+ login fine.

  3. #3
    Hi all,

    I upgraded the firmware to the latest version this morning and the problems seems to have been resolved. I will continue further testing and if not will update the thread.

  4. #4
    Ok, the version is 171218?

  5. #5
    I am having the same problem. How do I upgrade the firmware, can you help me

  6. #6
    How do you upgrade

  7. #7
    How do you upgraded?

  8. #8
    I am having same issues with TL-WA855RE V2. Running latest firmware TL-WA855RE(UK)_V2_171218 Macbook Pro unable to connect. Says WPA2 password incorrect but works fine on iPad, windows laptops and android phones.
    Last edited by jameslewisuk; 03-04-2018 at 09:17.

  9. #9

    Fixed !

    I did some searching online and found this firmware

    This fixed it for me, my Macbook pro now connects.

    I wonder if a non-beta update will be released?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.