Model :

Hardware Version :

Firmware Version :


I am using a TL-SG108E to provide individual VLAN's to offices with shared internet. Basically I configured as VLAN101 port 1&8, VLAN102 port 2&8 etc with port 8 connect to Virgin Media router. An ethernet cable from port 1 to a network switch in the first office, port 2 to a Belkin Wifi Access point in the second office, port 3 to a switch in the 3rd office.
All worked well for a few weeks and it has done what I intended, stopping printers etc in one office being accessible from the others.
The problem came when a put in another Wifi Access Point in the 4th office. It works as expected for about 20min then both Wifi access points cannot connect to the internet (or the router). The ports not connected to an access point (1 & 3) still work fine. Rebooting the SG108E restores access or another 20 minutes or so. I have tried 2 different routers (set as access points) and the same happens with both. Both access points have DHCP disabled and have different ip address & different SSIDs.

What is going wrong? I was expecting a smart switch to help improve the reliability of the network by (partially) isolating the separate offices but it has made it worse. How can an access point (or any other device) on one VLAN effectively shut down another VLAN?

Any help would be greatly appreciated.