Model :

Hardware Version :

Firmware Version :

ISP : [/COLOR]

Hello TP

I congratulate you on offering https support for the administration of the MR400 LTE/4G router. That's not always available from other vendors. However, it appears you do not support TLS 1.2, only TLS 1.0, and the certificated used it considered and treated by unsafe by today's security standards and browsers.

While using https may be fine on a local home LAN, remote administration is not possible from a security perspective as using this cert and TLS1.0 encryption would be unsafe. I ask that you consider upgrading transport layer encryption for administration of this device in a future firmware update.

Reinhard