Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Unhappy Problem with IPv6: please add an option to set the MTU on the dhcp server

    Model : Archer C7

    Hardware Version : v4.0

    Firmware Version : 1.0.5 Build 20171101 rel.37754(5553)

    ISP : [/COLOR]

    I recently bought an Archer C7, and tried IPv6. The router gets the IPv6 via PPPOE just fine, and the clients too. But it breaks most sites.
    After a lot of test, I realized the problem is that the PPPOE has an MTU of 1480 (maximum 1492), and the clients get configured with MTU 1500.
    IPv6 doesn't allow packet fragmentation, so packets bigger than 1480 get lost.
    Setting the MTU on the pc to 1480 solves the issue. But configure all PCs manually is not an option.

    It looks like Router Advertisement can set the MTU of the clients, so PLEASE, add an option to customize that.
    Or make this value automatically match that of the wan interface (pppoe in my case).
    The MTU of the IPv6 clients MUST match the MTU of the wan interface. Else IPv6 won't work correctly.
    Last edited by alpe; 01-29-2018 at 02:36.

  2. #2
    Please TP-Link, add "AdvLinkMTU 1480;" to the RADVD conf. Or 1280 to be usable with everything (1280 is the minimum allowed). Or better yet, add an option so we can customize it.
    Last edited by alpe; 01-28-2018 at 20:13.

  3. #3
    Please fix this. I can't enable IPv6 without mannually configuring every single client. At least give some feedback.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.