Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Wrong firmware on TL-MR6400, can't upgrade.

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]


    To made a terrible mistake today: Loaded a V1 firmware on a V2 TL-MR6400 ... (see below as to why this happened).
    I still can access the router via LAN and WLAN, but I cannot upgrade the firmware and I cannot reset to factory defaults.

    I currently have firmware 1.0.8 Build 150906 Rel.52604n loaded.

    a.) upgrading the firmware always results in: "The connection was reset" right after I hit "yes" in the confirmation dialog.
    b.) resetting to factory defaults always results in:

    Error code: 20
    Error occurred, please try again.

    right after the confirmation.

    So I'm stuck. I know that this is pretty dumb ... any ideas how I can rescue my TL-MR6400 ?? I already tried different browsers (Chrome, Firefox, IE) but no
    avail. I also tried power cycling the box several times.

    I'd appreciate any hints ...

    Thanks a lot // Tom

    P.S: Reason why this happened: The firmware download web page told me to double check that I have the right firmware for my router. And it also said I should check the country page --- so I checked the country page and it re-directed my to the Austrian local TP-LINK page where only this old firmware was available. So I thought this would be the right one ....
    Last edited by tomleitner; 01-18-2018 at 10:05.

  2. #2
    Junior Member swede is on a distinguished road
    Join Date
    Feb 2018

    Did you get an answer


    I have just done the same thing. did you get an answer or did I turn the router into a brick.

  3. #3
    No sorry. I'm still stuck with it. I can load an older version of OpenWrt on the device, this this older version does not support the hardware fully.
    So it basically works but I cannot re-flash the newest version. Somehow the firmware seems to come in two parts: A firmware/software part and a modem part.
    Using the V1 has apparently overwritten both parts.
    I did not have time to deal with this any longer ... Maybe someone else finds a solution ..
    Cheers // Tom


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.