Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 2 of 2
  1. #1

    Archer c2300 slow LAN speeds for gigabit

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    this is the 2nd device same issue.

    internal router speed test 600+mpbs , wifi 250mpbs, direct to modem 600+mpbs. BUT if I connect anything to the LAN ports its capped at 50mpbs. even putting NIC to full 1000 and the router to full 1000 on that port makes no difference.

    using surface pro 4, windows 10 pro.

    have tried my sons surface pro and gaming systems on LAN. all capped at 50mpbs. usually the speed tests are between 35-50.

    I have tried disabling firewall, and ALG. didn't make a difference.

    if I change to 100mpbs on the ports, I will get that speed, however if its on gigabit the port slows down to 50mpbs.

    Technicolor Cable Modem. cloned Mac

  2. #2
    Have you checked the connection speed?
    If your connection speed is 1Gbps, you would better contact TPlink support.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.