Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    Junior Member eman201 is on a distinguished road
    Join Date
    Jan 2018

    AC750 Archer C2 doesn't have access to the internet intermittently

    Model : Archer C2

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I got this router yesterday and set it up fine. Internet works fine with no hiccups when we're connected. However, periodically, the router won't have an internet connection. My computer is wired and it won't have a connection and all my connected devices won't either. They will be connected to the network but won't have internet access. It's not a modem issue because I have directly connected my computer to it and it works fine. I haven't changed anything on the login webpage of the router. It's just really annoying having to power on/off my router every couple of hours. I just updated the firmware version this morning so hopefully that has fixed it but my up time is only about 30 minutes since then so I could run into the same issue. If i can't get this resolved then I'm going to have to replace this with something else.

    Any help on the issue will be greatly appreciated thank you

  2. #2
    Hi eman201,
    glad to read you on this point. I was about to post about a problem like yours.
    I had to reboot my Archer C2 twice yesterday because the entire network crashed, both wifi and lan.
    my system is:
    Firmware Version:0.9.1 5.0 v0032.0 Build 170207 Rel.49213n
    Hardware Version:Archer C2 v1 00000001
    Peripherals connected to wifi stayed connected but no network.
    The wired ones were cut from internet and local network did not work
    It's the first time i meet this problem. I already had some wifi troubles with no internet, just had to power off wifi and it came back.
    In this new case I Reboot the routeur to had the entire network work again. Yesterday I had to do it twice in the day.
    I didn't made changes since a long time ago in my setup so I can't understand.
    Hope it help to resolve our trouble.

  3. #3

    Same or similar issue

    Firmware Version:0.9.1 3.16 v0348.0 Build 170531 Rel.56347nHardware Version:Archer C2 v5 00000005I have had similar experiences since I purchased my router Andy plugged it in a few days ago. My previous router did not have these issues, so I know itís not the internet connection. I use wireless exclusively and have my connection cut out multiple times throughout the day. It usually connects back to the internet if I wait about a minute, but it happens pretty often. Usually when I turn on a device like a phone/tablet. Typically waiting it out or turning off then on WiFi fixes it but it takes about a minute either way. I read something about google home max and one of the other TP Link routers but I have Google Home and Google Home Mini. Not sure if itís related since itís a different router and device but maybe?

  4. #4
    I just came across this article which may be relevant: https://www.engadget.com/2018/01/16/...ource=Facebook it looks like I have the latest firmware already, unless thereís a beta version with a fix for the Archer 2?

  5. #5
    Junior Member Timdel is on a distinguished road
    Join Date
    Jan 2018

    My Archer C2 worked fine for the past 4 months. Now it has started disconnecting randomly and I have to restart it several times each day. I came across other posts on the forum of people having same problem with other models. In one post someone suggested turning off the 5ghz mode. i have tried this and my Archer C2 seems to be stable again. No good if you need to run 5ghz mode though

    Firmware Version:0.9.1 5.0 v0032.0 Build 170207 Rel.49213n
    Hardware Version:Archer C2 v1 00000002

  6. #6
    Hi all,
    Back to this thread to share a detail I found today.
    Since yesterday, my phone has no wifi connection on my network.
    Rebooting the device didn't solved the problem.
    The night past and today still no connection on this device.
    So I logged in the C2 to see the DHCP clients. The phone seemed to be connected but when I turned off the phone the MAC adress and its IP where still on the network.
    I reserved an IP adress to the device and reconnect on both wifi network A/B/G/AC and no connection.
    Rebooting the C2 solved the problem.

  7. #7
    I also figured out my problem was related to another device. We have a digital reflections meter and after returning my router and getting a different one we had the same issues return and found the root of the issue to be the meter.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.