Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    Junior Member tafkap is on a distinguished road
    Join Date
    Jan 2018
    Posts
    1

    Archer C9 V2 upgrade to last firmware version 160315 and no 5 Ghz available

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hi all,

    yesterday i have upgraded my Archer C9 v2 with the last firmware available, the 160315 version here : http://uk.tp-link.com/download/Archer-C9_V2.html#Firmware

    T
    he upgrade went well but now i lost my 5 Ghz connection. However in the interface Web (new cool IHM), all is correct. I'm so disappointed. Is there a known issue with this firmware ? Can i come back with an older version ?

    I hope sincerely you will be help me....

    Cheers,
    Eric C.

  2. #2
    Maybe you need try this firmware http://static.tp-link.com/Archer%20C9(UN)_V2_170511.zip
    I found it at tplink official website (http://www.tp-link.com/en/download/A....html#Firmware)

  3. #3
    Did you use the correct FIRMWARE for the country you are in? and obviously the correct Version number , there is a known issue about this though.

    I am not sure what country the link Lurvelly posted is from, in the firmware weblink I see a 'en' in the web address which I think is Estonia? , not England though ,
    and the zip file name has 'UN' in it, which is for ????

    that being said the 17 series Beta firmware on my C7 V2 is working well , no more having to reboot the router each day...

    KB

  4. #4
    Quote Originally Posted by Kbird View Post
    Did you use the correct FIRMWARE for the country you are in? and obviously the correct Version number , there is a known issue about this though.I am not sure what country the link Lurvelly posted is from, in the firmware weblink I see a 'en' in the web address which I think is Estonia? , not England though , and the zip file name has 'UN' in it, which is for ????that being said the 17 series Beta firmware on my C7 V2 is working well , no more having to reboot the router each day...KB
    Which firmware beta version are you using for your C7 V2 ?

  5. #5
    Quote Originally Posted by Archer77 View Post
    Which firmware beta version are you using for your C7 V2 ?
    The one from the 1st Sticky Post in this forum ..... post # 43 (below) there are CA, US and EU versions ( I think they use EU in Oz/NZ too?)

    there is also one for the C7 V3 and D9 V1 and several others....

    it is here http://forum.tp-link.com/showthread....l=1#post195886


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.