Model :

Hardware Version :

Firmware Version :

ISP : [/COLOR]

I just bought an Archer MR200.

Firmware Version:1.2.0 0.9.1 v004a.0 Build 170927 Rel.58861n
Hardware Version:Archer MR200 v2 00000001

I have 4 SIM card, called "50", "5", "K", "S".

"S" is a nano sim with adapter, all the others are mini sim.
"50", "5", "S" is from the same company.

All sim card works perfectly with other two 4G routers, from another brand.


I initially used the "50" sim, and everythings works perfectly.

Then, I tried to use the "S" sim, without fortune. I alway got "No Sim Card". I supposed this happen because of the adapter, also if I checked again the sim with adapter in another router and everything worked fine.
Just for testing, I successfully plug in "5" and "K" sims.

I switch back to the "50" sim, no problem.

After few days, I plug in the "5" sim, no problem

After few day, i switch back to the "50" sim, and I get the "No SIM Card" message.
I immediately tested the sim on another device, and everything was ok.
I tried again to plug in the "50" sim, and I always get the "No SIM Card" message.
I tried the "5" and the "K" sims, everything worked fine.

I tried factory reset from the Web interface, hard reset using the hardware button, clean the sims contacts with specific product but no luck.

Now the situation is: all the sims works without problems on two other devices.
"50" no longer works on MR200
"S" had never work on MR200

No traffic limit was reached, I double check this information on every sim.

Any suggestion?

Thanks, Fabio