Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Junior Member SlimmBoy is on a distinguished road
    Join Date
    Dec 2017

    Archer C2300 LAN ports only running 100Mbs

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I am struggling with getting my Archer C2300 V1.0 router to operate the LAN ports at gigabit speed. I have connected to all four ports (1 at a time) and tested but only get 100Mbs. I have changed Ethernet cable but still no gigabit connection.
    I have also reset to factory settings without success. Firmware is 2.0.0 Build 20170922 Rel. 32364 and the modem reports that this is the latest firmware version.

    Can someone offer suggestions on how to fix this problem?
    Thank you in advance...

  2. #2
    Are all your LAN devices operate at Gigabit speed also?

  3. #3
    I am having the same issue. gigabit internet speeds seem to cap at 50mpbs on LAN ports only. internet router speed test, wifi and direct to modem are fine. However wired conections do not put out more than 50mbps. I even replaced the router, same issue. Tried two different firmware's, same issue. Putting the port to full 1000 on the router and full 1000 on my NIC makes no difference either.

    If I switch to 100 full then I will get around 100mpbs download speeds. but if I try to do 1000 full I get only 50mpbs. It makes no sense being this is the 2nd new device I have tried

  4. #4
    I am seeing the same behavior on my Archer C8 v1 -- supposed to be gigabit ports, but won't run over 100Mbps. If I plug my laptop directly into cable modem, I get around 375Mbps. On the C8's web interface, under Advanced > System Tools > System Parameters, down at the bottom there's a Duplex section, and it offers Autonegotiation, 1000Mbps Full Duplex, 100Mbps Full Duplex, then others. If I change this from Autonegotiation to 1000Mbps Full Duplex, I lose my internet connection.

    Very irritating. If I can't find a fix, I'll be shopping for a new router. Paying the cable company for 300Mbps, but the router's choking it to 100 on my LAN & WiFi.

  5. #5
    Maybe you can contact tplink support they will help you out

  6. #6

    Cable length

    Quote Originally Posted by Lurvelly View Post
    Maybe you can contact tplink support they will help you out
    Did contact TP-Link support - they tried, but really had no suggestions. We finally wound up with maybe a cabling problem - it's a CAT-5e cable running maybe 60 feet, if that. For fun, I ran a CAT-6 down through the house - cable modem is in attic (third floor), TP-Link router on first floor. It did make a big difference - I'm now seeing 200Mbps+ on both wifi and wired. I still think I can do better. I am probably going to put the router in the attic adjacent to the cable modem, and see if that makes a difference. Run lines out to switches that will service my wired gear and wifi access points, and say to hell with the wifi on the Archer C8. If *that* doesn't improve things, I have a 5 port gigabit router by Ubiquiti networks that was about $55 on Amazon; I'll try that next to the cable modem and run out to my switches from there and see what happens.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.