Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    EAP Controller 1.0.6 Error: Fail to start mongo DB server

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I installed the EAP Controller as administrator, using an account with admin rights too and also tried to run the link Icon of EAP110 Controller as admin and I always get this error: Fail to start mongo DB server
    There is no windows event for it, so it's difficult to say why mongo DB doesn't start. I killed the mongodb process before retrying - unfortunately with the same error. I also reinstalled the software and also installed it on a virtual machine, both running Windows 7 Professional and both have way more disk space than 4GB! Can somebody help me?

    Kind regards ,Stefan
    Attached Images  

  2. #2

    EAP Controller 1.0.6 Error: Fail to start mongo DB server

    Model : TP-LINK EAP110, n300

    Hardware Version : ?

    Firmware Version : ?

    ISP : [/COLOR]

    EAP Controller installed on two Win7 Professional computer (1 physical/1 VM), as administrator and executing it with administrator rights but the same error occurs: "Fail to start mongo DB server" (PrtScreen in attachments)
    Name:  EAP Controller Error.png
Views: 0
Size:  21.8 KB
    HD space is enough, way more than 4GB. When retrying I always check if the service Extensible Authentication-Protocol is running, mongodb process is killed but no success. No Windows events logged to that occasion.
    When I start mongod.exe in the EAP110 Controller\bin folder, it opens shortly a cmd window and closes it immediately so I cant get any further information. Should this be like this?

    Thanks for any help & Kind Regards

  3. #3
    Why not upgrade your EAP Controller to the latest EAP Controller_V2.5.4_Windows?

    If you insist to continue with the old version, you can try:
    1. Totally remove and reinstall Omada Controller. When you uninstall Omada Controller, choose ‘No’ when the wizard ask if you want retain user data.

    2. Try to repair the data base by running the following command:
    cd "C:\Program Files (x86)\TP-LINK\Omada Controller\bin"
    mongod --dbpath "C:\Program Files (x86)\TP-LINK\Omada Controller\data\db" –repair
    Please always backup the data folder in this path: C:\Program Files (x86)\TP-LINK\Omada Controller\data, since this repair operation may damage the database if the database is too big.
    Last edited by Carat1; 12-26-2017 at 05:54.

  4. #4
    It seems that your EAP Controller version is too old.
    You can try to download a newer Controller version, such as 2.5.4

  5. #5
    Yea I tried it with 2 older versions first, which had problem to even start the Mongo DB (I just clicked myself through the tp-link website for my EAP110 and downloaded what it showed me). However, the newest correct version (for my country) can start the Mongo DB and also opens the Website properly, but it doesnt find the EAP device in the same subnet. It gets visible, if I turn off my Windows firewall. EAP itself defined incomming firewall rules to get access. I definied a permit for outgoing connections for the same EAP .EXE, but it didnt help. I'm waiting since 3 weeks for the TP-Link support to reply, but may someone else can help out?
    Last edited by SysAdminini; 01-08-2018 at 11:38.

  6. #6
    You need to not only upgrade your EAP Controller to the latest but also upgrade the EAP110 to the latest(shown as below) http://www.tp-link.com/en/download/E....html#Firmware

    Will you take a screenshot of your EAP Controller?
    Attached Images  

  7. #7
    The latest Firmware was already installed (by me), the one you have shown.
    Model: EAP110
    Firmware Version: 1.2.0 Build 20170915 Rel. 35854

    Hardware Version: V2
    However, I mentioned that it is visible when I turn off the firewall, so it has to be a windows firewall rule setting, because FW & SW is running with the newest version.
    Little comment for TP-Link: On the swiss website there is no Firmware at all to download.. come on..
    Last edited by SysAdminini; 01-10-2018 at 12:20.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.