Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 9 of 9
  1. #1

    Question RE305 Firmware Upgrade = New Unknown Password

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Basic Question: After the RE305 has been firmware upgraded to 171115, what is the new password?

    Full Story:
    After getting a new RE305 Extender, I tried it out in "extender" mode and then successfully converted it to my original intention: as an access point. The ISP router comes into my house at the front basement, so the use case for this RE305 is to sit at the center of the middle level with a wire to the router so that wifi works reliably at the back top-level bedroom (and elsewhere). I left the 2.4GHz router wifi "on" so there are 2 duplicate 2.4GHz APs and 1 new 5GHz AP.

    Along the way, I changed the admin/admin UID & password to a pair of my own making, which has worked fine ... until ...

    I noticed today that wifi devices (tablets & laptops) were sometimes showing up as "connected" but with "no internet", and one tablet suddenly started receiving updates by walking downstairs. The view from the RE305's web management showed "Internet Status: unknown" with a warning triangle on the "internet" icon. So the working theory is that connections through the RE305 were resulting in "no internet" and when a device hooked up to the original router, things worked again.

    Attempting to fix this without opening a post (such as this), after rebooting the device several times, I figured I should probably upgrade the firmware. However, after upgrading to the latest "RE305(US)_V1_171115", I am presented with a different TP-Link web management login screen than the original.

    The original login screen asked for both user ID and password on the same screen; admin/admin worked initially, then my changes worked thereafter. But now I get: "Welcome to use TP-LINK's Range Extender" containing only one unlabeled field, which was populated with dots, and a Login button. I naturally entered my new UID first, but that failed. I noticed when the field is blank it reads "password" inside. So I entered both my new password (failed) and "admin" also failed.

    Now I'm receiving warnings that I've used 5 of my 10 login attempts. So, hopefully without having to factory reset this thing, see original question at the top ... what's the new password?

  2. #2
    upgrade won't change the password. weird.
    Reset it is the simplest way to solve it

  3. #3

    Cool Good to Know

    Thanks! Good to know that it should not have changed and that I probably must go through with the reset and reconfigure.

    Here's a quick follow-up: Does anyone know if there's a password character limit imposed between the 8/16/16 and 11/15/17 firmwares?

  4. #4
    Still very much a thing ... I have two of these and it was the same for both. Resetting and reconfiguring does work, but it's a pain and shouldn't be necessary!

  5. #5
    after the reset, do you create a new password? or keep admin? do those welcome windows look the same before and after the reset?

  6. #6
    There's no way to create a new password, and neither "admin" nor the password I previously changed it to works. The window says simply "enter password" and gives you a field to enter it into. There is no field for user name, nor any other information. Only "enter password."

  7. #7
    but reset works? after the extender is reset, before the configuration, what password do you enter? what does the login window look like?

  8. #8
    After the extender is reset, everything goes to the out-of-the-box defaults; username and password both "admin". The updated firmware is maintained, so you do end up where you wanted to go. It's just a lot more difficult than it should be.

  9. #9
    Quote Originally Posted by sweissman View Post
    It's just a lot more difficult than it should be.
    Amen to that.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.