Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 10 of 10
  1. #1

    smart plug - worked and now it doesn't

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I have the square smart plug. it worked and then it quit. I have followed all the instructions and set it back to default, registered it over and over. I can dontrol it remotely with my phone but Alexa cannot find it. I am BEYOND frustrated.

  2. #2
    Members Ada is on a distinguished road
    Join Date
    Oct 2012
    Have you read this instruction: http://www.tp-link.com/us/faq-944.html ?
    And you can move the plug and echo close to each other to have a test.
    If this can't help, suggest you to contact support.usa@tp-link.com for help.

  3. #3
    I have read every instruction. I have spent a ton of time doing something that should be so simple. This board was my last resort.

  4. #4
    Did you upgrade the firmware version of your plug and also the version of the Kasa App and Alexa App?

  5. #5
    Are there any firmware updates for plugs (HS100 or HS110)? I don't know.

  6. #6
    The latest firmware is 1.1.3 for HS100 and 1.1.4 for HS110 EU version.
    You can find the current version on the device settings page of the plug on Kasa .

  7. #7
    No, I did not see anything. Kasa says, there are no updates?!

  8. #8
    Did you find the current firmware version?
    If the current firmware version is already the latest one, then it is normal to show no updates.
    Besides, there is another way to update if it is not the newest:

  9. #9
    i haven't seen any firmware BUT miraculously the thing is working again - on its own! I cannot tell you how much time I spent on the stupid thing. It has made me very wary of getting any more of the products.

  10. #10
    Like a magic. If the issue happen again, better to contact TP-Link support for help.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.