Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    HS100 smart plug and new Amazon Alexa App

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I have three types of smarthome devices, Philips Hue Lights, Sonos Speakers and more recently a TP-Link HS100 smart plug.I used the iOS iPhone Kasa app to set up the HS100 plug and linked it to my newly created Kasa account to allow remote control access to it. The plug was given the name 'Cabinet Lights' for reference purposes and I initially created two scenes in the Kasa App called 'Good Night' (which switched off the plug) and one called 'Movie Night' (which switched on the plug). I decided later the two scenes were not really necessary and deleted them in the Kasa App.Meanwhile I have a number of Amazon Echo Dots about the house and so decided to voice control the 'Cabinet Lights' smart plug device using Alexa.The next day, in the iOS Amazon App on my iPad, i went to the smarthome section of the app and added in the tp-link Kasa Skill, linking the same (one and only) Kasa Account in the process and then I scanned for devices.To my surprise, Alexa not only found my Cabinet Light HS100 smart plug, but she also found the two scenes (Movie Night and Good Night). The plug did of course work but the scenes produced an error (as expected).Now once upon a time you could 'forget' devices and scenes in the Amazon app and then rescan/rediscover deviceís but recently that option was removed from the Amazon App.So I could not remove the two non-existent scenes.I removed the tp-link Kasa Skill... but that left the devices and scenes in place ... I uninstalled the Amazon App and that didnít help either.I did a hardware reset of all my echo dots ... and that didnít solve it either.I recreated the scenes in the Kasa App but that then went onto create another two (identically) named 'duplicate' scenes in the Amazon Alexa App.I removed the HS100 device from Kasa and the scenes and eventually did a hardware reset of the smart plug itself and despite everything I have tried I still now have 4 deleted scenes called Movie Night, Good Night etc.. being discovered by Alexa.Two days of installing and uninstalling, resetting hardware, forgetting, scanning, rediscovering etc. etc .. and I still cannot solve this issue.So I thought itís time to join this forum and to now seek some help from the experts here, so if anyone can offer me any suggestions to fix this issue then I would be very grateful. I would rather not delete and recreate brand new Amazon or Kasa Accounts as I use the Amazon account for family music and movie subscriptions etc and Iím concerned that another (different) Kasa Account will only go onto create some further duplication of devices and scenes that I have already.I have contacted tp-link (who think itís an Amazon issue) and also telephoned Amazon Support (who think itís a tp-link/Kasa issue) .. and everyone has been very helpful but it has still not yet resulted in me solving this problem.Anyhow, if anyone has any suggestions for me to try, then please do get in touch.Thanks very much ... Mr. Ken Griffiths
    Last edited by flying snow; 11-09-2017 at 01:51.

  2. #2
    Actually you can send an email to support@tp-link.com, maybe TP-Link Technical meet the similar issue before and has a solution for it.
    You can also contact Amazon support, they may tell you why the forget option disappear on Alexa.

  3. #3
    flying snow,Thanks for the reply. I have contacted both support desks, who are escalating the matter as we speak, but they have not provided a solution so far, hence I decided to post the issue here to see if anyone else was perhaps having the same, or similar, issue and had discovered a way of solving it.Anyhow I have tried everything I can think of, including resetting all the hardware involved ...and still no joy!!

  4. #4
    No idea as well. Hope you can get a solution soon. Any update, share here

  5. #5
    Okay, thanks to a man called Bob on the Amazon forum, I have managed to fix the above issue.

    The new iOS Amazon app in the U.K. no longer allows a user to 'forget' smart home devices, or scenes, but there is an online web portal for the settings that are used by the Amazon app located here:

    https://alexa.amazon.co.uk/spa/index.html? ...(note it is best to access this site by a computer rather than a mobile device, as a mobile device tries to launch the installed app instead).

    ...and if you Login at that location the option to forget scenes and devices still exists. So I was able to login to the web based version and 'forget' the deleted Kasa scenes and this fixed the issue in my App.

    Problem solved at last.

    Ken
    Last edited by KGriff; 11-08-2017 at 07:07.

  6. #6
    Good sharing! Thanks!


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright © 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.