Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 5 of 5
  1. #1

    Trying to configure vlans and need some help

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I just received my two

    TL-SG105E switches and now i need to configure them but i am new to vlan configs. Here is my config i need and i hope someone can give me a hand with the switch setup.

    TL-SG105E A port 1 connects to TL-SG105E B port 1
    TL-SG105E A port 5 has a AP (Unifi AC Pro)
    TL-SG105E B port 5 has a AP (Unifi AC Pro)
    TL-SG105E B port 4 connects to pfsense LAN

    On my APs i created two WIFI SSID's
    SSID: TESTvlan46 with tagged with vlan 46
    SSID: TESTvlan50 with tagged with vlan 46
    SSID: TEST no vlan tag

    on pfsense router i have one LAN adapter configured with virtual adapters
    SSID: TESTvlan46 connects to 192.168.1.2 (DHCP 192.168.1.x)
    SSID: TESTvlan50 connects to 192.168.2.2 (DHCP 192.168.2.x)
    SSID: TEST (no vlan) connects to 192.168.0.2 (DHCP 192.168.0.x)

    The part i don't understand is how the switch's will handle when the ap's are sending data tagged with vlan 46, 50 or no vlan and how the switch's can keep this flowing to the router.


  2. #2
    In my opinion, you can check FAQ in TP-LINK website firstly. http://www.tp-link.com/en/faq-418.html

  3. #3
    Quote Originally Posted by TPTHZ View Post
    In my opinion, you can check FAQ in TP-LINK website firstly. http://www.tp-link.com/en/faq-418.html
    Thanks, yes i reviewed that doc and a few others but its not working for me....

    So i set VLAN ID to all ports as untagged.
    my current wifi with no vlan is working.
    Next i created the 46 vlan and tagged port 5 as that's the port with my AP
    This wifi wont connect.

    The second switch is the same as the first. the second has the same
    Port 1 connects to the first switch
    Port 5 is the second AP
    Attached Images  

  4. #4
    Quote Originally Posted by TPTHZ View Post
    In my opinion, you can check FAQ in TP-LINK website firstly. http://www.tp-link.com/en/faq-418.html
    Thanks, yes I was looking at a few other setup steps but not as clear as the one you posted so thanks for that. I am sure I still don't understand this but let me show you the new configed based on the link you sent (also see pic)

    So on each switch create a vlan for default. Set member ports 1-5 and untagged 1-5
    Switch 1 create a vlan with ID 46. Set member ports 1-5. Tag port 5 as that port has the AP. Untagg ports 1-4
    Switch 2 create a vlan with ID 46. Set member ports 1-5. Tag port 5 as that port has the AP. Untagg ports 1-4

    in this config, I can connect to the novlan SSID and everything works.
    When I connect to the 46 SSID, I don't get a ip from the router.

    Name:  Switch_Setup.jpg
Views: 0
Size:  38.4 KB

  5. #5
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,127
    The switch's port 4 and the router's port need to be tagged ports. PVID=1 for port 4 on the switch will still supply your novlan SSID. The router needs to provide DHCP for novlan (VLAN1, untagged) and also for 46Duffus (VLAN 46, tagged).


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.