Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 10 of 10
  1. #1

    KRACK WPA2 vulnerability

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    When will TP-Link release a patch for this WPA2 vulnerability?

    https://www.krackattacks.com/

  2. #2
    Junior Member CraigMc is on a distinguished road
    Join Date
    Oct 2017
    Posts
    1
    Yes, When?

  3. #3
    Our seniors are keeping an eye on this issue. Currently we haven't received any feedback that TP-Link product is affected by that. We will offer an update on our official website once we have any new info. please feel free to contact us if you have any feedback , thanks so much

  4. #4
    +1

    This attack works for everything WPA2, including linux, windows, macos, APs from ubiquiti, cisco, etc.
    All these vendors acknowledged the bug and are in various state of releasing a patch

    I am expecting acknowledgement and a patch from tp-link as well.

  5. #5
    Junior Member nosklo is on a distinguished road
    Join Date
    Oct 2017
    Posts
    2

    Exclamation TPLink acknowledge

    Looks like they have now acknowledged the issue.

    http://forum.tp-link.com/showthread....-WPA2-protocol

  6. #6
    Junior Member nosklo is on a distinguished road
    Join Date
    Oct 2017
    Posts
    2
    Quote Originally Posted by Irithori View Post
    +1

    This attack works for everything WPA2, including linux, windows, macos, APs from ubiquiti, cisco, etc.
    All these vendors acknowledged the bug and are in various state of releasing a patch

    I am expecting acknowledgement and a patch from tp-link as well.
    Looks like they have now acknowledged the issue.

  7. #7
    At least all wifi „extenders“ i.e. repeaters are likely to suffer from the bug. Everthing using wpa_supplicant and hostapd in previous versions, too.

  8. #8
    TP-Link is aware of the vulnerabilities (KRACKs) in the WPA-2 protocol. We have published a security advisory on the official website and are working to solve the problems now.
    Security Advisory: http://www.tp-link.com/en/faq-1970.html
    Software updates for the affected devices will be post at www.tp-link.com/support.html over the next few weeks

  9. #9
    Quote Originally Posted by TP-Admin View Post
    TP-Link is aware of the vulnerabilities (KRACKs) in the WPA-2 protocol. We have published a security advisory on the official website and are working to solve the problems now.
    Security Advisory: http://www.tp-link.com/en/faq-1970.html
    Software updates for the affected devices will be post at www.tp-link.com/support.html over the next few weeks
    Thanks for the info

  10. #10
    thank you TP Link


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.