Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 6 of 6
  1. #1

    Unhappy Problems connecting TL-SG108E to Virgin Superhub 3 router

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I have recently connected a TL-SG108E switch to my Virgin Superhub 3 router to allow me to connect additional devices (Printer & 2 Samsung Smart TVs) by Ethernet.
    AFter adding the switch the printer worked fine. Then after a few days, my wifi connections (phones & iPad) would only connect to the LAN but not the Internet. Virgin's tech support got me to enable the Guest network on the router and this allowed the wifi devices to connect to the Internet but the private network would not. Simultaneously;y my TVs failed to connect to the Internet but were connected to the router. My printer continued to function through the switch as dis 2 Pcs and aNAs connected to the router. I checked with TP-Link support to make sure I had the right settings on the switch ( I had simply plugged it in and connected the ethernet cables). they confirmed that this was the correct configuration.
    Yesterday a Virgin engineer came out and replaced my router. The Superhub 3 has had a lot of problems so seemed the likely culprit especially after the GuesNetworkork fix. The replacement router gave the same problems so the engineer disconnected the 4 ethernet cables from the router at which point the private wifi network connected to the Internet. He then reconnected each ethernet cable in turn and when the cable from the switch was connected the wi-fi dropped out after about 30 seconds. THis happened repeatedly when the cable was disconnected then reconnected again. This, of course, let Virgin off the hook and the engineer left. Later I checked on various on-line forums and there we lots of issues reported regarding switches connected to the Superhub 3.
    Today I reconnected the switch having first tested the Cat6 cables for faults. The wi-fi connected fine on the private network, so I reconnected the Samsung TVs. On testing one of them I got an internet connection but it took ages to connect. Eventually I managed to steam a film on Plex from a remote server but after about 10 minutes the connection failed. 20 minutes later the wi-fi connection on my phone dropped and wouldn't connect to the Internet. I disconnect the switch from the router and the wifi connection returned.
    So there's seems to be some compatibility issue between the switch and the router. The router lists the devices connected to the switch in it's DHCP table but not the switch itself. The printer seems to connect OK via the switch. My next test will be to connect a TV by ethernet directly to the switch. I did this when the problem first arose and the TV would not connect but I still had the switch connected, so I will need to try the test again with the switch disconnected. The TVs though seem to fail to connect only when the wifi is failing to connect.
    Has anyone experienced similar problems or am I missing some simple setting or tweak that is needed either on the router or the switch?

  2. #2
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,127
    Quote Originally Posted by avogadro View Post
    The replacement router gave the same problems so the engineer disconnected the 4 ethernet cables from the router at which point the private wifi network connected to the Internet. He then reconnected each ethernet cable in turn and when the cable from the switch was connected the wi-fi dropped out after about 30 seconds. THis happened repeatedly when the cable was disconnected then reconnected again.
    Change the default IP address 192.168.0.1 of the TL-SG108E to some other free, unused IP, e.g. 192.168.0.2 or whichever is free in your network topology. It collides with the default IP of the Virgin router and this causes the problems you are observing.

    Took me 3 seconds to find out using a search on the net that the Virgin router by default uses the same IP address as the switch. Are you sure that the guy from Virgin is really an engineer? And he did not realize that the switch is a managed switch and checked for its IP?
    Last edited by R1D2; 09-24-2017 at 09:43.

  3. #3
    Thanks for the advice R1D2. After installing the switch originally I reset the IP address to 192.168.0.10 having followed the instructions that came with the switch. Later, after the problems appeared I talked to TP-Link support and was told that was not necessary and I should rest the switch and leave it in its 'as supplied' config. Last night after posting to this thread I again reset the IP address of the switch to 192.168.0.10 and then noticed that the default gateway was set to 0.0.0.0. I changed this to 192.168.0. as used by all the other devices on the LAN1 and everything started working. No wifi drop out and my TVs are connecting by ethernet.

  4. #4
    Members R1D2 is on a distinguished road
    Join Date
    Dec 2015
    Posts
    1,127
    Glad it works. TP-Link support is wrong claiming you could leave it at its default IP. If the router uses this IP (192.168.0.1) - as is the case with Virgin Superhub -, you must change the switch's default IP to another one.

    The default gateway of the switch can be left empty or should be set to the router's IP. It's uncritical except if you use some special setups with VLANs.
    Last edited by R1D2; 09-25-2017 at 17:33.

  5. #5
    My favorite approach - if the router supports it - is to deploy the switches in DHCP-client mode, and assign them a static IP in the router's DHCP server. That way, IP address configuration is kept in one central instance, and you can still find your infrastructure hardware at a constant address.

  6. #6
    I always configure new hardware on an isolated machine before deploying them into the live network - even at home.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.