Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 3 of 3
  1. #1

    Archer C9 V1 stuck during firmware update , now i cant access it.

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    Hello everyone

    I bought my Archer C9 Ver:01 two months ago and was quite satisfied with its performance . I connected Seagate 4TB to the USB 3.0 port of the router and enjoyed file sharing fully until one day when i pulled out the HDD from it and re connected it after sometime. The file sharing stopped working. I went through alot of TP link forums to get solution but didnt find anything . i decided to upgrade firmware and downloaded the latest from TP link support (c9v1_un-up-ver4-1-0-P31[20160517-rel35411) and installed it. The router started working but again there was issue in file sharing . I got so frustrated and tried to downgrade it .. so i downloaded ( archer_c9v1_eu-up-ver3-18-0-P1[20151125-rel64793] ) from TP link support ,But during downgrade , the process stopped at 20% . i waited almost 60 minutes but it was stuck there and all the LED lights on the router were going ON and OFF , led lights remain ON for 10 seconds and go OFF for 10 seconds time. i turned off the router , unplugged the power cable and restarted it after 5 minutes but it was same ( all LED lights turning ON and OFF). I tried hard reset by pressing the WPS/reset button for 10 seconds to 20 seconds but no result.

    I need help regarding the issue explained

    Adnan

  2. #2
    I guess your router is bricked. Not sure what the warranty policy is in Pakistan, but usually you can contact the reseller/distributor to get it replaced if router is under warranty.

  3. #3
    yes, unit replaced under warranty


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.