Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Junior Member JayBee1982 is on a distinguished road
    Join Date
    Sep 2017

    Range extender TL-WA850RE not connecting anymore to router anymore.

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I've been using the TL-WA850RE Range Extender for over a year now, without any big problems, besides the fact that the internet connection sometimes drops when another device comes online. But since yesterday the Range Extender doesn't seem to be picking up the router's signal anymore, leaving one corner of my apartment (my office!) without internet connection. At first I tried putting the extender near the router and make them connect by pressing the WPS buttons on both devices, but nothing happened. Then I tried rebooting both the router and the extender, but to no avail. I also tried downloading the TP link App to help with re-installation, but the App can't find the Extender. I'm kind of lost what to do now. Any help would be greatly appreciated!

  2. #2
    How about the lights on the extender?
    If you cannot see TP-LINK_Extender wifi, can reset it first(plug into the reset hole and press for 10 seconds until all the lights flash), then refer to this link to set it up: http://www.tp-link.com/en/faq-698.html


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2018 TP-LINK Technologies Co., Ltd. All rights reserved.