Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 7 of 7
  1. #1

    Exclamation Firmware update on TC-W7960

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    how do I update firmware on TC-W7960

    currently running Firmware Version:v1.0.3 Build 20160127 Rel358240

    running into constant connection drops requiring power reset every 2hrs to keep wifi alive

  2. #2
    For cable modem, you just simply power it off and on, wait a few minutes, firmware will be updated if any.

  3. #3
    I have this same question because of similar issues (random drops, No matter how many times I turn off IPv6 DHCP on the router it still is giving out IPv6 addresses, the "Year" on Advanced->System Tools->Time Settings is "1970" with no way to change, the Time Zone constantly resets to GMT-8:00, etc.)

    I can find no Firmware to download from TP-Link's site, nor anyplace in the Router's menu to check/look for/update firmware.

    There doesn't seem to be any mention of Firmware (or how to upgrade it) in the User Manual, though I will be more than happy to be told I overlooked it if it is there!

    Currently:
    Firmware Version:v1.0.3 Build 20160127 Rel358240Hardware Version:V1.1


  4. #4
    I received a response from TP-Link support, saying I need to contact my ISP to get the firmware. I'm in the process of that now... concerned that my ISP is going to say "Since this is a personal router and not one we provide, we can't (won't) upgrade the firmware." but hopefully that isn't how this is going to end.

  5. #5
    11
    Shield101

    I have done that multiple times there is no update to firmware or option on the admin page to do so? It would be helpful if you can point in TP_LINK literature?

  6. #6
    Sadly, what I expected, has happened. I worked with three separate people in three separate areas of my ISP, and the end result was the same: "We can't do anything because that isn't our hardware. You'll have to go back to TP-LINK to get the firmware update." Let me be clear, the ISP people were friendly, and the third person I talked with took more than an hour working with me to try and find some solution, so I wasn't "blown off" by my ISP. But that really doesn't matter in the end because for the moment I am stuck with a Modem/Router that doesn't function as expected, and two companies pointing at each other going "go talk to them to fix it."

    This is still not the end of this story however. I have opened a case with TP-LINK and we are communicating via email. They asked *why* I need (or think I need) a firmware update, and I explained the issues I'm seeing with my TC-W7960:

    I've been looking to upgrade the Firmware because the TC-W7960 (Cable Modem Router) has several issues:


    1) Under Time Settings, for Daylight Saving Time, the year is hard coded to "1970". There is no way to edit that field. Even with the TC-W7960 set to use NTP and getting the correct date and time, that field does not change. So that makes it impossible to use the rest of the Daylight Saving Time settings (Month, Day, etc.) since they refer incorrectly to dates in 1970 instead of the current year.

    2) I can set the Timezone to my local timezone, but about 80% of the time when I reboot the TC-W7960 (for any reason) the Timezone changes back to the default of GMT-8.

    3) (The biggest issue) When I have unchecked all settings and told the TC-W7960 that I do NOT want it to perform DHCP for IPv6, it continues to give out IPv6 IP addresses. I have another device on my network that handles DHCP (both IP4 and IP6), so I don't want the TC-W7960 providing either for me.

    4) There have been several times the TC-W7960 has dropped access to the Internet. looking at logs it gives no clear reason, but often there are both Time and IPv6 error messages around the time the connection dropped.


    I had made an assumption there was a newer firmware that would fix all these things, such as the version 1.1.0 in the Emulator at TP-LINK's site that doesn't appear to have all these problems. I am currently waiting to hear back from TP-LINK now on these issues and if there is a way to address them remotely (Again, I would have assumed a firmware update) or if it's down to me shipping my TC-W7960 back to TP-LINK.

  7. #7
    Today's update: After about 36 hours of hearing nothing, Support has asked for screenshots and logs to confirm what I am reporting as being wrong. Screenshots and logs have been sent to support. I hope to hear something within a few hours on what the next step will be, though again I'm not sure what that step may be other than me shipping the TC-W7960 back to TP-LINK and having more downtime.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.