Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Junior Member amadaras is on a distinguished road
    Join Date
    Sep 2017
    Posts
    1

    TP-Link TL-PA4020P Internet Connection Problem

    Model : TL-PA4020PTKIT

    Hardware Version :

    Firmware Version :

    ISP : UPC H[/COLOR]

    Hi,
    I bought this Powerline adapter today and I encountered some problems. The router is on the ground 1st floor of the house, the target PCs are on the 2nd. I connected two ethernet cables to the connectors of the adapter, I connected both PCs to the adapter upstairs. I got the two adapters connected, but internet speeds are poor, or there's no connection at all on one of the PCs. The other PC does not even have any connection, not even temporarily. I have no idea what the cause problem is, nor how I could solve it.
    Thanks for all of your help in advance,
    amadaras

  2. #2
    First of all, the powerline adapter in 1st floor should be connected to the router via one ethernet cable only, and make sure all the 3 lights are lit up on the adapter.
    If still no connection upstairs, there might be interference between those two adapters. Move the adapter upstairs to a different outlet. And move away from high power appliances. It's hard to tell which appliance affect it, so you need to do some tests. Or compare it by moving the adapters in the same floor or same room to test if they can work.


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.