Welcome to TP-LINK Tech Support Forum
+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    Junior Member Creative! is on a distinguished road
    Join Date
    Aug 2017
    Posts
    2

    Cool EAP controller software on a Raspberry Pi?

    Model :

    Hardware Version :

    Firmware Version :

    ISP : [/COLOR]

    I wanted to ask if the controller software is running on a Rasbarry Py (under Snappy Ubuntu Core), since I can get so much power, and have a durging disposition. On the Rasbarry is echoing only a Slimmed version of Ubuntu.


    Thanks in advance for the answer!

  2. #2
    Probably it could run on a Pi 3 Model B, but limitation still would be the Pi's RAM. I doubt that it would be much fun to run the EAPC on it.

  3. #3
    Junior Member leadpoizon is on a distinguished road
    Join Date
    Sep 2017
    Posts
    2
    I just tried this and unfortunately it doesn't work. TP-Link has not compiled the binaries included in the install package for ARM processors, which is what Raspberry Pis use. I wish they do this, because that would be a very nice power efficient way to manage the APs.

    FYI, I tested on the Raspberry Pi Zero W with Raspbian Stretch and received the following error during installation:

    Code:
    /opt/tplink/EAPController/bin/portt: Cannot execute binary file: Exec format error

  4. #4
    Junior Member leadpoizon is on a distinguished road
    Join Date
    Sep 2017
    Posts
    2
    Unfortunately, before memory, the restriction comes from the binaries that are not compiled for ARM processors. I was hoping it would work, since they seems to have a Java requirement. Some of the utilities during the installation are not compiled for ARM. I tried this on a Raspberry Pi Zero W on Raspbian Stretch and recievied Exec format error. I wish TP-Link would make their software cross-platform.

  5. #5
    It makes not much sense to compile SW for tiny SoC boards if the boards don't meet all other requirements to run the controller.

  6. #6
    Hi all!
    I am working on a solution and I have got some promising results on a raspberry pi zero W.
    I will write a full post on my solution once I have got it to work reliably.

    In the mean time, here are some hints.

    /opt/tplink/EAPController/bin/portt: Cannot execute binary file: Exec format errorThis error is due to the portt binary which is for x86 architecture whereas the raspberry pi has an arm architecture.
    The portt binary is only used in file controller.sh, you can replace the call in controller.sh or skip it and replace it with a long delay.

    The included jre is for x86. You will have to replace it with the raspberry's. The raspberry's jre doesn't support -server option, you have to replace it with the -client option.

    The controller also uses mongodb, you have to replace the binaries by the raspberry's.

    I have managed to make it work, just wait a few days and I will publish a full patch for the raspberry

  7. #7
    Junior Member Windar is on a distinguished road
    Join Date
    Sep 2017
    Posts
    2
    Hi there, will follow this closely as the possibility of running the EAP Controller on a Raspberry Pi (3 model B in my case) would definitely be very interesting


 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Copyright 1996-2017 TP-LINK Technologies Co., Ltd. All rights reserved.