PDA

View Full Version : 4g modem frequently disconnecting TL-MR3420



scream
06-09-2013, 19:00
Region : India

Model : TL-MR3420

Hardware Version : V2

Firmware Version :

ISP : bharti airtel

datacard: huawei e392u-92
2g/3g/lte modem

router: TL-MR3420

Firmware Version:
3.13.27 Build 121206 Rel.60215n

Hardware Version:
MR3420 v2 00000000

problem:

1: data card is shown as dentified but no signal strength indication ... always shows 0%
[not listed in compatibility list but it works]

2: it works pretty well but disconnects every 20 mins with router
[directly with laptop same works for hours i checked for 8 hrs in a row and it was working fine]

with the same sim same apn huawei e173 [2g/3g] works very well without disconnecting at the same plac with same router

--------------------------------------------------------------------------------log file-----------------------------------------------------------------------------------------
Index Time Type Level Log Content
30 1st day 00:13:34 3G/4G NOTICE mobileLinkUpdate 351 LTE is disconnect
29 1st day 00:13:34 PPP WARNING 3G/4G disconnected
28 1st day 00:13:33 3G/4G NOTICE swLteMobileCmdReq 488 call pLteModemDev->disconnect()
27 1st day 00:13:31 3G/4G NOTICE dhcpcLteModemRelease 1035 sysCmd = ifconfig lte0 0.0.0.0
26 1st day 00:13:30 DHCP NOTICE dhcpc_ipc_data_rcv_lte 222 g_lteConTimes = 1
25 1st day 00:13:30 DHCP INFO dhcpc_ipc_data_rcv_lte 204 lte_net_info.status = 0x2 lte_net_info.ip = 0x0, lte_net_info.mask = 0x0, lte_net_info.gw = 0x0
24 1st day 00:13:30 DHCP INFO dhcpc_ipc_data_rcv_router 692 : current network type = 1
23 1st day 00:13:30 DHCP INFO DHCPC Entering released state
22 1st day 00:13:30 DHCP INFO DHCPC Unicasting a release of 10.151.106.159 to 10.151.106.129
21 1st day 00:13:29 3G/4G INFO swLteMobileCmdReq 482 call disconnect
20 1st day 00:13:29 3G/4G INFO swLteMobileCmdReq 401 lteLinkStatus == 1
19 1st day 00:03:24 DHCP INFO LTE Network connected.
18 1st day 00:03:24 DHCP WARNING dhcpc_ipc_data_rcv_lte 313
17 1st day 00:03:23 DHCP INFO Update DNS1 = 0x3b907f09, DNS2=0x3b907f0a
16 1st day 00:03:23 DHCP INFO dhcpc_ipc_data_rcv_lte 263 dhcpstr.ip = 10.151.106.129
15 1st day 00:03:23 DHCP INFO dhcpc_ipc_data_rcv_lte 204 lte_net_info.status = 0x0 lte_net_info.ip = 0xa976a9f, lte_net_info.mask = 0xffffffc0, lte_net_info.gw = 0xa976a81
14 1st day 00:03:23 DHCP INFO dhcpc_ipc_data_rcv_router 692 : current network type = 1
13 1st day 00:03:23 DHCP INFO DHCPC:GET ip:a976a9f mask:ffffffc0 gateway:a976a81 dns1:3b907f09 dns2:3b907f0a static route:0
12 1st day 00:03:23 DHCP INFO DHCPC Recv ACK from server a976a81 with ip a976a9f lease time 7200
11 1st day 00:03:22 DHCP INFO DHCPC Send REQUEST to server a976a81 with request ip a976a9f
10 1st day 00:03:22 DHCP INFO DHCPC Recv OFFER from server a976a81 with ip a976a9f
9 1st day 00:03:22 DHCP INFO DHCPC Send DISCOVER with request ip 0 and unicast flag 0
8 1st day 00:03:20 DHCP INFO dhcpc_ipc_data_rcv_lte 204 lte_net_info.status = 0x1 lte_net_info.ip = 0x0, lte_net_info.mask = 0x0, lte_net_info.gw = 0x0
7 1st day 00:03:20 DHCP INFO DHCPC Send DISCOVER with request ip 0 and unicast flag 0
6 1st day 00:03:20 DHCP INFO dhcpc_ipc_data_rcv_router 692 : current network type = 1
5 1st day 00:03:20 3G/4G NOTICE swLteMobileCmdReq 457 call dhcpcLteModemStart
4 1st day 00:03:17 3G/4G INFO Set APN airtelgprs.com and authType 0x0
3 1st day 00:03:17 3G/4G INFO swLteMobileCmdReq 401 lteLinkStatus == 0
2 1st day 00:03:17 3G/4G NOTICE 3G/4G start connecting...
1 1st day 00:03:02 OTHER INFO User clear system log.
Time = 2012-01-01 0:18:52 1133s
H-Ver = MR3420 v2 00000000 : S-Ver = 3.13.27 Build 121206 Rel.60215n
L = 192.168.0.1 : M = 255.255.255.0
3G/4G : 3G/4G = 0.0.0.0 : M = 0.0.0.0 : G = 0.0.0.0

---------------------------------------------------------------------------------------------------------------------------------------------

gakbik
06-17-2013, 13:45
I have the same problem of frequently cut of the internet, do you have any solution to this problem or I have to restart my router each 20 minutes !!

OmPrakashm22
06-27-2013, 10:27
I am using the airtel 4g dongle with MR3420. I do not have any problem.

Have you tried the bin file for E392?

Wahroonga Farm
06-28-2013, 05:13
Depending on your location, signal strength and data throughput speed, the power needs of a 4G modem will vary and may rise to 800mA at 5v.

If the router cannot supply this power the modem will fail or loose connection.

If this is your scenario then some of the strategies outlined in the following link may be of some value:

http://www.ofmodemsandmen.com/powert.html

kishork
10-06-2013, 21:08
I am using the airtel 4g dongle with MR3420. I do not have any problem.

Have you tried the bin file for E392?

where is the bin file for E392u-92 (Huawei E392 of Airtel)

kishork
10-13-2013, 05:49
I have the same problem of frequently cut of the internet, do you have any solution to this problem or I have to restart my router each 20 minutes !!

i have same setup - 3420 and Huawei E392u-92 and i was having same set of problems which i resolved as mentioned in my below thread:

http://forum.tp-link.com/showthread.php?73036-3420-and-4G-modem-two-tricks-which-worked-for-me-(may-be-it-works-for-you)&region=china

hope it helps..